Switching Notes
ScriptExample Script List
CommandExample Commands
etherchanneletherchannel
interfaceinterface gig
interface rangeinterface range fa0/11-12
ip dhcp poolip dhcp pool pool2
ip routeip route 192.168.1.0 255.255.255.0 192.168.5.4
vlanvlan 10
showsh ip int gi | include access
RTPReliable Transport Protocol
ip routeip route
IP Poolip Pool = ip Scope
S - Static Route
C - Directly Connected
L - Dynamically Learned
show vlan brief
C - Directly Connected
L - Dynamically Learned
configure terminal
hostname RTR-Alex
no ip domain-lookup
ip domain-name ScriptDomain.text
END
configure terminal
interface gigabitethernet 0/0
description "GigabitEthernet 0/0"
ip address 192.168.1.254 255.255.255.0
no shutdown
END
configure terminal
interface gigabitethernet 0/1
description "GigabitEthernet 0/1"
ip address 192.168.100.1 255.255.255.0
no shutdown
END
configure terminal
enable secret cisco
username admin password password
banner motd # unauthorized access restricted #
END
configure terminal
line vty 0 4
transport input ssh
login local
logging synchronous
END
configure terminal
Line con 0
exec-timeout 9 0
password class
login
logging synchronous
END
configure terminal
line aux 0
password class
logging synchronous
login local
END
configure terminal
router ospf 1
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
network 192.168.5.0 0.0.0.255 area 0
network 192.168.6.0 0.0.0.255 area 0
network 192.168.100.0 0.0.0.255 area 0
end
configure terminal
ip default-gateway 192.168.1.254
service password-encryption
crypto key generate rsa general-keys modulus 1024
END
copy running-config startup-config
startup-config
Back to index


!##########[ Routing and Redistributions ]##########
conf t
router ospf 1
network 192.168.100.0 0.0.0.255 area 0
network 192.168.200.0 0.0.0.255 area 0
redistribute eigrp 1
end
conf t
router eigrp 1
redistribute ospf 1 metric 100000 100 255 1 1500
network 192.168.100.1
network 192.168.200.2
network 192.168.34.0
end
metric, bandwidth(K), delay, reliable, laod, mtu

bandwidths are in K
KActualCommon Name
1,000,0001,000,000,0001G
100,000100,000,000100M (Fast Ethernet)
10,00010,000,00010M

Delay_
10u1,000Mbs
100u100Mbs
1,000u10Mbs


reliable - higher better 1-255
load - lower better 1-255
MTU - Ethernet, always 1500

! ########## [ DHCP ] ##########

! configure terminal
! ip dhcp pool LAN
! network 192.168.1.0 /24
! dns-server 10.1.1.20
! default-router 192.168.1.254
! end