RIP - Routing Information Protocol
A commonly used routing protocol in small to medium TCP/IP networks. It is a stable protocol that uses a distance-vector algorithm to calculate routes.
RIPBased on hop count
FOR ROUTER 0
=============================
enable
configure terminal
no ip domain-lookup
hostname Router0
line console 0
exec-timeout 0
exit
interface serial 0/0/1
ip address 192.168.0.1 255.255.255.252
no shut
interface serial 0/0/0
ip address 192.168.2.1 255.255.255.252
no shut
interface fastethernet 0/0
ip address 10.0.0.1 255.255.255.252
no shut
interface fastethernet 0/1
ip address 192.168.1.1 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 10.0.0.0
auto-summary
exit
exit
end
FOR ROUTER 1
=============================
enable
configure terminal
no ip domain-lookup
hostname Router1
line console 0
exec-timeout 0
exit
interface serial 0/0/1
ip address 192.168.0.2 255.255.255.252
no shut
interface fastethernet 0/1
ip address 192.168.0.5 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.0.4
network 192.168.0.0
auto-summary
exit
exit
end






FOR ROUTER 2
=============================
enable
configure terminal
no ip domain-lookup
hostname Router2
line console 0
exec-timeout 0
exit
interface serial 0/0/1
ip address 192.168.0.6 255.255.255.252
no shut
interface fastethernet 0/1
ip address 192.168.0.9 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.0.4
network 192.168.0.8
auto-summary
exit
exit
end






FOR ROUTER 3
=============================
enable
configure terminal
no ip domain-lookup
hostname Router3
line console 0
exec-timeout 0
exit
interface serial 0/0/0
ip address 192.168.2.2 255.255.255.252
no shut
interface fastethernet 0/1
ip address 192.168.2.5 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.2.4
network 192.168.2.2
auto-summary
exit
exit
end






FOR ROUTER 4
=============================
enable
configure terminal
no ip domain-lookup
hostname Router4
line console 0
exec-timeout 0
exit
interface serial 0/0/0
ip address 192.168.0.2.1 255.255.255.252
no shut
interface fastethernet 0/1
ip address 192.168.2.6 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.2.1
network 192.168.2.6
auto-summary
exit
exit
end





FOR ROUTER 5
=============================
enable
configure terminal
no ip domain-lookup
hostname Router5
line console 0
exec-timeout 0
exit
interface fastethernet 0/1
ip address 192.168.1.2 255.255.255.252
no shut
interface fastethernet 0/0
ip address 192.168.1.5 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.1.0
network 192.168.1.4
auto-summary
exit
exit
end






FOR ROUTER 6
=============================
enable
configure terminal
no ip domain-lookup
hostname Router6
line console 0
exec-timeout 0
exit
interface serial 0/0/1
ip address 192.168.0.10 255.255.255.252
no shut
interface fastethernet 0/0
ip address 192.168.1.6 255.255.255.252
no shut
exit
interface serial 0/0/0
ip address 192.168.2.1 255.255.255.252
no shut
interface fastethernet 0/1
ip address 20.0.0.1 255.255.255.252
no shut
exit
router rip
version 2
network 192.168.0.8
network 192.168.1.6
network 192.168.1.6
network 20.0.0.0
auto-summary
exit
exit
end