LACP - Link Aggregation Control Protocol
Link Aggregation Control Protocol (LACP) provides a method to control the bundling of several physical links together to form a single logical link. LACP allows a network device to negotiate an automatic bundling of links by sending LACP packets to their peer, a directly-connected device that also implements LACP.
The command channel-group mode active enables LACP unconditionally, and the command channel-group mode passive enables LACP only if the port receives an LACP packet from another device. The command channel-group mode desirable enables PAgP unconditionally, and the command channel-group mode auto enables PAgP only if the port receives a PAgP packet from another device.
hostname S1
interface port-channel1
switchport trunk allowed vlan 10,20
switchport mode trunk
interface fastethernet 0/1
switchport access vlan 10
switchport mode access
interface fastethernet 0/2
switchport access vlan 20
switchport mode access
interface gigabitethernet 0/1 switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode active
interface gigabitethernet 0/2
switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode active
hostname S2
interface port-channel1
switchport trunk allowed vlan 10,20
switchport mode trunk
interface fastethernet 0/1
switchport access vlan 10
switchport mode access
interface fastethernet 0/2
switchport access vlan 20
switchport mode access
interface gigabitethernet 0/1 switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode passive
interface gigabitethernet 0/2
switchport trunk allowed vlan 10,20
switchport mode trunk
channel-group 1 mode passive